Subject: dns search paths with KAME
To: None <>
From: Ronald Khoo <>
List: current-users
Date: 07/14/1999 14:09:20
[   I'm not sure where best to ask this.  It could be on a KAME or
    IETF list that I'm not on, or it could be on tech-net,
    but since it's just a "user-visible change of behaviour in -current"
    I thought here would be best.  Feel free to point me gently
    in a more appropriate direction :-) ]

Now that KAME has been integrated and work done on making NetBSD userland
IPv6 aware, I've got a problem with dns search paths.  Note that I'm
not an IPv6 hacker, nor do I have an IPv6 network, I'm simply
an ordinary -current user with a tiny IPv4 network at home :-)

The problem goes like this:

	% telnet broccoli

previously just worked.  It found IN A in my
local name server and everything worked.  Now, however, it fails
to find IN AAAA and looks for broccoli. IN AAAA
before failing on that and looking for IN A.

When my modem is switched off, this takes a while :-)

(oh, and you won't find those hosts in the real world DNS -- this is
 private DNS in a rfc1918 network)

Now, given that my kernel doesn't have IPv6 in it, I guess I could
work around the issue by putting some AAAA records in my DNS, but
that seems to be a non-obvious thing to do in a non-v6 network.

telnet now uses getaddrinfo(3) which is documented in RFC 2553.
RFC 2553 doesn't seem to mention DNS search paths. 

Question is, is this now to be considered integrated NetBSD code,
so do I just submit a NetBSD PR, or what?  Or is this not
considered a bug ?  (hope not!)