Subject: web lossage again.. (PCIIDE debug option?)
To: None <>
From: Andrew Gillham <>
List: current-users
Date: 07/12/1999 12:00:03
Ok, so what is the correct XXX_DEBUG option to enable the ATAPI
probe and other diagnostic infomation?  The CDROM for my Dell
notebook isn't being recognized when it is plugged into the slot
on my docking station.  It works in the internal notebook slot
though.  And.. once it worked in the docking station, when I hadn't
popped it in early enough for the BIOS to find it.  Yet, try as I
might, I can't reproduce that. :(

Anyway, the debug options didn't jump out at me, and I couldn't
search the mailing lists, so here I am.. :)

Here's my dmesg output.

NetBSD 1.4F (DRAGON) #0: Mon Jul 12 09:58:10 EDT 1999
cpu0: family 5 model 8 step 1
cpu0: Intel Pentium (586-class)
total memory = 97856 KB
avail memory = 88296 KB
using 1248 buffers containing 4992 KB of memory
mainbus0 (root)
pci0 at mainbus0 bus 0: configuration mode 1
pci0: i/o enabled, memory enabled
pchb0 at pci0 dev 0 function 0
pchb0: Intel 82439TX System Controller (MTXC) (rev. 0x01)
pcib0 at pci0 dev 1 function 0
pcib0: Intel 82371AB PCI-to-ISA Bridge (PIIX4) (rev. 0x01)
pciide0 at pci0 dev 1 function 1: Intel 82371AB IDE controller (PIIX4)
pciide0: bus-master DMA support present
pciide0: primary channel wired to compatibility mode
wd0 at pciide0 channel 0 drive 0: <IBM-DTCA-24090>
wd0: drive supports 16-sector pio transfers, lba addressing
wd0: 3909MB, 7944 cyl, 16 head, 63 sec, 512 bytes/sect x 8007552 sectors
wd0: 32-bits data port
wd0: drive supports PIO mode 4, DMA mode 2, Ultra-DMA mode 2
pciide0: primary channel interrupting at irq 14
pciide0: secondary channel wired to compatibility mode
pciide0: secondary channel ignored (disabled)
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2 (using DMA data transfers)
uhci0 at pci0 dev 1 function 2: Intel 82371AB USB Host Controller (PIIX4) (rev. 0x01)
uhci0: interrupting at irq 11
uhci0: USB version 1.0
usb0 at uhci0
uhub0 at usb0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
Intel 82371AB Power Management Controller (PIIX4) (miscellaneous bridge, revision 0x01) at pci0 dev 1 function 3 not configured
vga1 at pci0 dev 2 function 0: Neomagic MagicGraph 128XD (rev. 0x00)
wsdisplay0 at vga1: console (80x25, vt100 emulation)
Texas Instruments PCI1131 PCI-CardBus Bridge (CardBus bridge, revision 0x01) at pci0 dev 3 function 0 not configured
Texas Instruments PCI1131 PCI-CardBus Bridge (CardBus bridge, revision 0x01) at pci0 dev 3 function 1 not configured
ppb0 at pci0 dev 17 function 0: Intel 82380FB Mobile PCI-to-PCI Bridge (MPCI2) (rev. 0x01)
pci1 at ppb0 bus 1
pci1: i/o enabled, memory enabled
pciide1 at pci1 dev 5 function 0: CMD Technology PCI0646
pciide1: bus-master DMA support present
pciide1: primary channel configured to native-PCI mode
pciide1: using irq 10 for native-PCI interrupt
pciide1: secondary channel configured to native-PCI mode
pciide1: secondary channel ignored (disabled)
ahc0 at pci1 dev 7 function 0
ahc0: interrupting at irq 10
ahc0: Using left over BIOS settings
ahc0: aic7860 Single Channel, SCSI Id=7, 3 SCBs
scsibus0 at ahc0 channel 0: 8 targets, 8 luns per target
sd0 at scsibus0 targ 5 lun 0: <IOMEGA, ZIP 100, C.19> SCSI2 0/direct removable
sd0: drive offline
ex0 at pci1 dev 8 function 0: 3Com 3c905-TX 10/100 Ethernet
ex0: interrupting at irq 10
ex0: MAC address 00:c0:4f:f5:b1:29
exphy0 at ex0 phy 24: 3Com internal media interface
exphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
isa0 at pcib0
com0 at isa0 port 0x3f8-0x3ff irq 4: ns16550a, working fifo
lpt0 at isa0 port 0x378-0x37b irq 7
pckbc0 at isa0 port 0x60-0x64
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0
pcppi0 at isa0 port 0x61
sysbeep0 at pcppi0
isapnp0 at isa0 port 0x279: ISA Plug 'n Play device support
npx0 at isa0 port 0xf0-0xff: using exception 16
fdc0 at isa0 port 0x3f0-0x3f7 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB, 80 cyl, 2 head, 18 sec
pcic0 at isa0 port 0x3e0-0x3e1 iomem 0xd0000-0xd3fff: using irq 9
pcic0: controller 0 (Intel 82365SL Revision 1) has sockets A and B
pcmcia0 at pcic0 controller 0 socket 0
pcmcia1 at pcic0 controller 0 socket 1
isapnp0: no ISA Plug 'n Play devices found
apm0 at mainbus0: Power Management spec V1.1
apm0: battery life expectancy: 100%
apm0: A/C state: on
apm0: battery charge state: high
apm0: estimated 3h 36m
biomask 4c40 netmask 4c40 ttymask 5ec2
IPsec: Initialized Security Association Processing.
ex0: supplying EUI64: 00:c0:4f:ff:fe:f5:b1:29
boot device: wd0
root on wd0a dumps on wd0b
root file system type: ffs
ex0: starting DAD for fe80:0001::02c0:4fff:fef5:b129
ex0: DAD complete for fe80:0001::02c0:4fff:fef5:b129 - no duplicates found
wsdisplay0: screen 1 added (80x25, vt100 emulation)
wsdisplay0: screen 2 added (80x25, vt100 emulation)
wsdisplay0: screen 3 added (80x25, vt100 emulation)
wsdisplay0: screen 4 added (80x25, vt100 emulation)