Subject: USB-printer -> system halt
To: None <>
From: Bjoern Labitzke <>
List: current-users
Date: 07/05/1999 09:13:19

I am running -current from yesterday on my Pentium-II. I have an Asus
P2L97S motherboard, which features an USB controller from Intel. I bought
a Brother HL-1050 laser printer which has an USB interface as well.

I have been using this setup with some other -current versions as well and
found the USB part working good enough. Ok, there were some errors which
disconnected and reconnected the printer and sometimes the data sent to
the printer seemed to lack a few bytes at the start, but all in all it
went good enough. But this morning (I haven't printed yet since usbd is
gone) I tried to print an important document I had been editing a few
minutes before. I wanted to use dvilj, which worked before. But this time
my system just hung. Nothing at all worked any longer: The mouse was
frozen, the clock stopped, etc. The only way to get control back of my
system was a power cycle. (... and somehow I lost my file at this moment.
After the power on only 0 bytes were left :-( )

Ok, I guess I learned a bit from that. But how am I going to print again?
Which information do I need to provide (and how do I get it?) to help
solving this? As I lent my RS232 cable to a friend, I _need_ the USB
interface for printing.

Any help appreciated,