Subject: -current?
To: None <>
From: Michael G. Schabert <>
List: current-users
Date: 06/21/1999 09:35:48
(posted to port-alpha & current-users)
System: AlphaStation 4/200 166Mhz

Hi all,
Is anyone else having trouble compiling -current? I had been running 1.4
release, & went to go -current. First, I compiled a new kernel & rebooted.
So far so good. Then I tried to make build, where it churned for hours &
then stopped. I had lost connection before it finished, so it was compiling
without a terminal, so I couldn't see where it ended. I supped the next
day's sources, & compiled a new kernel, but that one wouldn't
died with either a pmap or uvm problem. I read Jason say that something
related was fixed for the following day's sup, so I waited & again supped.
This time, kernel compiled, & worked (1.4D)...back to the userland. Now
it's failing with:

cc1: warnings being treated as errors
/usr/src/gnu/usr.bin/gawk/../../dist/gawk/getopt.c: In function
/usr/src/gnu/usr.bin/gawk/../../dist/gawk/getopt.c:606: warning: type
mismatch in implicit declaration for built-in function `strlen'

It first failed with that 2 days ago, so I waited until yesterday,
resupped, & tried compiling again...but JUST USERLAND (I left the previous
day's kernel). It failed the make the same way. Is there something wrong on
my system, or is this a known problem?

Bikers don't *DO* taglines.