Subject: Re: Upgrade bad for s/key login?
To: Julian Coleman <>
From: Manuel Bouyer <>
List: current-users
Date: 05/31/1999 16:57:39
On Fri, May 28, 1999 at 06:47:27PM +0100, Julian Coleman wrote:
> Having upgraded from 1.3.2 to 1.4 (Sparc 4), I find that I can no longer
> log in using s/key.   The one time password that I generated under 1.3.2
> doesn't work under 1.4 (I'm stuck at 61).  I tried to generate a new
> list under 1.4 and the one time password for challenge 61 is different from
> the 1.3.2 one but still doesn't work.  Any thoughts? (Apart from generate
> a new list when I'm back at the machine.)  Is s/key supposed to work through
> upgrades?

I tried on 1.3.3 and 1.4 i386 and sparc hosts.
For the same skey sequence# and key (whith the same passwd of course :),
sparc 1.3.3, sparc 1.4 and i386/1.4 gives the same result, but i386/1.3.3
gives a dufferent one. Maybe a endian problem was fixed (I didn't notice it
but as I don't use S/key I may well have missed it) ?

Manuel Bouyer, LIP6, Universite Paris VI.