Subject: Re: problems with second ide drive
To: Manuel Bouyer <>
From: Christos Zoulas <>
List: current-users
Date: 05/22/1999 02:38:05
On May 20,  8:56am, (Manuel Bouyer) wrote:
-- Subject: Re: problems with second ide drive

| On May 19, Christos Zoulas wrote
| > [...]
| > wd0(pciide0:0:0): using PIO mode 0, DMA mode 1 (using DMA data transfers)
| > wd1(pciide0:0:1): using PIO mode 4
| That's the problem: the PIIX can't use different modes for the master and
| slave device, so there's a bug in the driver.
| Could you try the attached patch ? It should even allow DMA to properly
| work.
| > | Did you try to newfs again the filesystems before ? It may be possible that
| > | some table got corrupted, which are not checked by fsck.
| > 
| > I would consider this a serious bug in fsck then...
| I already tracked something like this down. Some tables are computed at newfs
| time and stored on disk, then never changed, so fsck doesn't check them.
| But I don't know how to check and correct them. Using the newfs algorithm
| works, but I'm not sure other OS's newfs would produce the same table.

Well I tried your patch and it put both disks on pio mode 0 dma mode 1.
The newer (second drive) did not work. I rebooted with the kernel that
had flags on wd1 so that it would use only pio mode instead of dma and
it worked fine again. Then stinky (my old machine) died so I cannot test
with it anymore. It died when I tried to make the new disk master and
the old disk slave. Oh well.. no more testing for me!