Subject: wierd routing problem
To: None <>
From: John F. Woods <>
List: current-users
Date: 05/13/1999 22:32:54
I have a fairly traditional setup, NetBSD 1.4 box with modem to the
internet and an ethernet card for the house network; I also have a
routed /24 for the home network (gotten way back when they were still
encouraging organizations to apply for class C blocks if they ever
*might* attach to the Internet).  I have an iMac on the Ethernet which
I use for web browsing.  The important IP adresses are:

OK, here's the strange part.  Just after I updated my main system to
1.4 (from mid-April current sources), I became unable to reach from the iMac; instead, bizarrely enough, I get
connected to my own web server on!  Yet, I have no
trouble getting to any other web server I've tried.

It gets stranger.  If I use a traceroute program on the mac and do a
traceroute to (, it goes one hop and
stops, evidently satisfied, with a packet marked as coming from  Yet if I try or, it goes
all the way out to the net and ends up at the appropriate host after
an entirely plausible traceroute.

A mac problem?  I don't think so:  if I do a netstat -a while the iMac
is connected to my webserver (after I tried to contact, I see this:

$ netstat -a | less
Active Internet connections (including servers)
Proto Recv-Q Send-Q  Local Address        Foreign Address          State
tcp        0      0  jfwhome.www          proxyi.emirates..64027   TIME_WAIT
tcp        0      0  localhost.www        localhost.64359          TIME_WAIT
tcp        0      0         imac.2051                ESTABLISHED
tcp        0      0  jfwhome.www          proxyi.emirates..63758   TIME_WAIT
tcp        0      0         imac.1864                FIN_WAIT_2 is an alternate name for the address in question; yet
evidently the NetBSD box believes that is a reasonable IP address to have
as a local address!

And yet:  if I run a web browser on the NetBSD box, I can get to just fine.  (Hmm, a second mac on the network gets the
anomalous result.)

So it seems that there is a routing problem.  I (of course) don't have
an explicit route; all I have is this:  ( is the address
of the ISP side of my PPP link)

$ route show
Routing tables

Destination      Gateway            Flags
default      UG    UH
localhost          UH    link#1             U     0:40:5:a1:d4:ac    UH
millan           0:5:2:eb:90:64     UH
familymac        0:0:c5:42:ad:eb    UH
imac             0:5:2:43:2:b0      UH

(The appletalk routes had *better* *not* have anything to do with

So, any ideas?