Subject: Re: how to crash a diskless client (i386)
To: Manuel Bouyer <>
From: None <>
List: current-users
Date: 05/10/1999 10:21:39

> [...db trace snipped...]
> Did it panic ? If so, what's the panic message ?
no, at least the message doesn't begin with "panic:...". the message
when stopping is:

kernel: protection fault trap, code=0
Stopped in dd at   _wdc_ata_bio_intr+0x372:	repne insl	%dx,%es:(%edi)

> This is "EHOSTDOWN", which means that your client didn't anserw ARP requests.
> Quite possible if is was crashed :)
oui! ;-)
I've tried several blocksizes with dd but there's no change in
behaviour. beeing in single or multiuser doesn't matter, too.

just tried to reboot my client and got the "kernel: protection fault
trap..." while fsck'ing /var. hm!...

next I tried dd'ing with a kernel booted from floppy (the
install-floppy from the april 21. snapshot) and got:

wdc:0:0:0: Lost interrupt
	   type: ata
	   c_count: 6144
	   c_skip: 4096
kernel: protection fault trap, code 0
Stopped in dd at   _wdc_ata_bio_intr+0x372...

Hm! What now? a problem with the disk? with the motherboard? (it's
some old Asus-board with a SIS chip-set: 11/27/95-SiS-496-497b-PVI-4SP3C-00,
"IDE HDD Block Mode" is Enabled in the bios, "IDE 0 Master Mode" is
Auto, "Onboard IDE Prefetch Buf" is Enabled, the disk is autodetected
with "size 849, cyls 832, head 32, sector 63, LBA"(*) and the board
sometimes doesn't like to initialize the graphics card when powered up
and needs to be reset, or powercycled again...)

(*) netbsd sees the disk as:
wd0: 810MB, 1647 cyl, 16 head, 63 sec, 512 bytes/sect x 1660176 sectors
            ^^^^      ^^
but disklabel uses 822 cyl, 32 tracks/cyl, 63 sec!

is this the problem?

a little puzzeled,


Here's the output of dmesg for reference:

NetBSD 1.4 (OPAC) #7: Fri May  7 15:47:17 MEST 1999
cpu0: family 4 model 8 step 4
cpu0: AMD Am486DX4 W/T or Am5x86 W/T 150 (486-class)
real mem  = 24772608
avail mem = 21688320
using 328 buffers containing 1343488 bytes of memory
mainbus0 (root)
isa0 at mainbus0
ep0 at isa0 port 0x300-0x30f irq 10: 3Com 3C509 Ethernet
ep0: address 00:60:08:53:39:30, 8KB byte-wide FIFO, 5:3 Rx:Tx split
ep0: 10baseT (default 10baseT)
wdc0 at isa0 port 0x1f0-0x1f7 irq 14
wd0 at wdc0 channel 0 drive 0: <QUANTUM TRB850A>
wd0: drive supports 8-sector pio transfers, lba addressing
wd0: 810MB, 1647 cyl, 16 head, 63 sec, 512 bytes/sect x 1660176 sectors
wd0: 32-bits data port
wd0: drive supports PIO mode 4, DMA mode 2
npx0 at isa0 port 0xf0-0xff: using exception 16
vt0 at isa0 port 0x60-0x6f irq 1
vt0: generic, 80 col, color, 8 scr, mf2-kbd, [R3.32]
vt0: console
biomask 4000 netmask 4400 ttymask 4402
boot device: ep0
nfs_boot: trying RARP (and RPC/bootparam)
nfs_boot: client_addr=0x865df0d4 (RARP from 0x865df00b)
nfs_boot: server_addr=0x865df00b
nfs_boot: hostname=opac12
root on dino:/c2/NetBSD/i386/netboot
root file system type: nfs