Subject: binutils pkg build? (or: NOT CVSup ;-)
To: None <>
From: Michael G. Schabert <>
List: current-users
Date: 05/01/1999 16:21:45
Hi all, I was looking to cross-compile a kernel for a friend, but when I
tried to make the binutils it didn't work. This is with pkgsrc supped
yesterday (4/30/99) on a kernel & system built yesterday.

prez# pwd
prez# make install
>> Checksum OK for binutils-2.9.1.tar.gz.
===>  Extracting for cross-binutils-
===>  cross-binutils- depends on file: /usr/pkg/bin/pkglibtool-1.2p1
- found
/usr/bin/tar: -X not found in archive
/usr/bin/tar: /usr/pkgsrc/cross/binutils/files/exclude not found in archive
===>  Patching for cross-binutils-
===>  Applying NetBSD patches for cross-binutils-
patch: **** can't cd to /usr/pkgsrc/cross/binutils/work/binutils-2.9.1: No
such file or directory
Patch /usr/pkgsrc/cross/binutils/patches/patch-aa failed
*** Error code 1


At this point, there's a /usr/pkgsrc/cross/binutils/work directory, but the
only thing in that is .extract_done, & as the error points out, there's no
binutils-2.9.1 within the work directory.

Now, I just manually cd's into the work directory & ran a
tar -zxpX /usr/pkgsrc/cross/binutils/files/exclude -f

so that fixed it on my system (well, at least it's past there & is
currently configging :), but my question is whether it was something on
just my machine that caused the arguments to tar to be messed up or whether
something is wrong in netbsd's current setup.

Bikers don't *DO* taglines.