Subject: Unkillable processes...
To: NetBSD current-users <>
From: Bjoern Labitzke <>
List: current-users
Date: 04/25/1999 17:32:52

Some time ago I wrote about that problem already, but couldn't reproduce
it. I still can't, but it just occured again. vgetty (from the sendfax+
mgetty package) "tried to exit" according to the ps manpage, but
couldn't. I couldn't kill it either, so I tried to reboot. shutdown -r
started the shutdown which proceeded upto the message that the discs were
synced. There it hang for over a minute, so I figured it hung forever.

Those hangs are a bit more frequent now (somehow they are triggered by
some kind of call to my "answering machine" modem, still need to figure
it out completely), so I will try to gather more data the next times. But
if anyone knowledgeable can guess a problem, he might check the source to
fix it before 1.4.

I am running the "current" 1.4 Beta build from the source of Friday
evening (so it should be the source made available by Fridays supscan.) on
the i386-architecture. Any further data needed? 

Bye, Bjoern

Bjoern Labitzke  <>
   Use PGP! (Don't you use envelopes for your letters?)