Subject: Re: machine rebooting
To: Dustin Sallings <>
From: Kevin M. Lahey <>
List: current-users
Date: 02/23/1999 16:40:06
In message <>,
Dustin Sallings writes:
>	Today, I start the VPN, do a couple things over it, and run my
>websplat application and the machine reboots.
>	Actually, I just figured out the difference while I was typing
>this...  websplat by default tries to make as many connections as it can
>to a web server and issue queries.  I was limiting it to two yesterday for
>my tests.  Today, I forgot that option...  After it gets going a little,
>the machine completely freezes up and reboots.  No core or anything.  Is
>there any possible way to figure out what it's doing here?  I can't think
>that this is a good behavior for PPP.  My kernel is dated 1/12/1999.

Hmmm.  I don't know.  I've been seeing similarly perplexing behaviour
on a couple of hosts here when opening lots of connections.  I have
a simple test program which forks and execs a number of rcp's to 
a remote system.  When I run it on four systems, each of which is
opening 30 connections, I can get the target (which is trying to
handle 120 total rcp's) to crash repeatably.

I worried that it was hardware initially, so I just switched the disks
in two boxes and got my repeatable crash.  I'm a little aggravated,
as this happens with all of the DEBUG and DIAGNOSTIC switches on
in the kernel, but it goes with no warnings, no messages, nothing.
It just clears the screen and reboots.

I'm still not *totally* convinced that it isn't hardware;  these are
moderately funky SuperMicro Pentium Pro motherboards with I2O and 256MB 
of RAM.  I'll try to reproduce this on some other hardware.

Just another "Me, too",