Subject: stuck with -current (19990216)
To: None <>
From: Andreas Eltrich <>
List: current-users
Date: 02/17/1999 21:37:45

I've some problems with my Sparc Classic running -current. Originally the
machine was a Sparc Classic X, but it was changed to a normal Classic after
doing the hack described in the nvram-hostid-faq. This box was running
-current fine for several months. I did the last successful make build on
January 31th.

Last weekend I tried to upgrade again, but the build failed while linting

 -I. -DPOSIX_MISTAKE -DFLOATING_POINT -i /usr/src/lib/libc/stdio/vfprintf.c
/usr/src/lib/libc/stdio/vfprintf.c(497): cannot dereference non-pointer type
/usr/src/lib/libc/stdio/vfprintf.c(499): cannot dereference non-pointer type
/usr/src/lib/libc/stdio/vfprintf.c(501): cannot dereference non-pointer type
/usr/src/lib/libc/stdio/vfprintf.c(503): cannot dereference non-pointer type
*** Error code 1


Yesterday I upgraded the toolchain to 19990215. I rebuilt the complete gnu
tree, furthermore make, lint, ld, lex, yacc, mkdep and install. After
running sup again and upgrading to 19990216 I rebuilt a kernel, but this
kernel doesn't boot anymore. It says:

>> NetBSD/sparc Secondary Boot, Revision 1.8
>> (elchy@serva, Wed Feb 17 08:36:22 CET 1999)
Booting netbsd @ 0x4000
OBP version 3 (plugin 2, revision 2000c)
panic: bootstrap: could not get interrupt node from prom
Program terminated

The Classic is equipped with a ROM Rev. 2.12. I even rebuilt the bootloader
and reinstalled it on disk, but this didn't help. I had to boot an older
kernel to get back a working machine.

After that I tried again to rebuild the world, but it fails again at the
same point I mentioned above.

What am I doing wrong???

Another problem: I also rebuild xsrc regulary, but during last weeks there
appeared several problems that aren't fixed yet. First the perfect keyboard
support got lost. Unfortunately I have to deal with a german type-5
keyboard. This worked fine without defining any additional xmodmaps until
around christmas. Then suddenly some keys stopped working. Now I have to set
at least the follwing xmodmap:

keycode 0x31 =	asciicircum	degree		notsign
keycode 0x48 =	plus		asterisk	asciitilde
keycode 0x5F =	numbersign	apostrophe	grave
keycode 0x83 =	less		greater		bar

Furthermore the LED toggling of the Compose and the Scroll key does not
work anymore.

About two weeks ago the autorepeat mechanism of the keyboard got lost. This
is very annoying, since I found no workaround for this bug. xset thinks,
the autorepeat is on, but actually it isn't.

% xset q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
  auto repeating keys:  00ffeffbffffffff

Perhaps I should mention that my Sparc SLC with type-4 us keyboard also
does not autorepeat anymore. The SLC shares /usr (and the X server) with
the Classic.

Please please can someone fix this before I get crazy while hammering on
the same keys again and again... ;-/

thanks, Elchy

 Andreas Eltrich  ( ( )    ( ) )  Mail:
 Munich, Germany  `-^-^-@@-^-^-'
 Tel: +49-89-54379757  (..)  Fax/Modem: +49-89-54379758