Subject: Re: /root/.termcap (was Re: tried to move /usr)
To: NetBSD-current Discussion List <>
From: Brian C. Grayson <>
List: current-users
Date: 01/23/1999 19:54:02
On Sat, Jan 23, 1999 at 08:05:46PM -0500, Greg A. Woods wrote:
> > Subject: Re: /root/.termcap (was Re: tried to move /usr)
> >
> > Brian C. Grayson wrote:
> > 
> > |  Would it be a Bad Idea to install a minimal /root/.termcap that
> > |held, say, vt100 vt220 pcvt25 pccons (and any other basic ones
> > |for each arch)?  We mount /usr/share via NFS, and if there are
> Has this thread got anything to do with that totally misleading message
> printed by vi in single user mode when TERM is unset:
>         ex/vi: Error: unknown: No such file or directory
> I've had a note to myself about this for some time, but since I normally
> only use vi when I am in single user mode, I usually forget to poke
> around and find where this is coming from and why it doesn't say what it
> really means....

  Yes, that's how this thread started on port-mac68k -- "What
does that message mean, and how do I fix it?" IIRC.  The problem
is, if TERM is unset, it is apparently set to "unknown".  Then vi
tries to look up term info for unknown, and fails because termcap
isn't accessible (or some similar sequence of events -- I'm not
a termcap guru).  We probably ought to patch vi to either catch
this case and print something more useful ("No termcap database
accessible?"), or in its early stages print something like
"Warning:  no TERM environment variable set.  Using 'unknown'."
Or both -- there are actually two distinct non-niceties here!