Subject: Re: RAIDFrame problems
To: Paul Newhouse <>
From: Greg Oster <>
List: current-users
Date: 01/23/1999 00:09:37
Paul Newhouse writes:
> Platform i386

What vintage of -current? (i.e. based on sources of what date?)

> I've defined 3 disks in a raid-5 with the following raid config file :
[snip reasonable config file]
> which works fine.  I also did the raidctl(s) to initialize the
> raidframe driver and initialize the parity info (takes about
> an hour). 

The following will also work in this case, and be *much* quicker :-)

 dd if=/dev/zero of=/dev/rwd1b bs=2m 
 dd if=/dev/zero of=/dev/rwd2b bs=2m 
 dd if=/dev/zero of=/dev/rwd3b bs=2m 

(adjust 'bs' to taste :-) )

> However, that all worked.  Then I made a file system
> on the resulting raid device (newfs -b 8192 -f 1024 -c 32 /dev/rraid0b).
> That also takes about 15 to 20 minutes.  Then I mounted it, and
> everything seems to work. Great!  Then I try a simple command:
> dd if=/dev/zero of=/space/test1 bs=256k count=1024
> The raid device started recording data and then just stopped.  Any
> attempt to look at that file system or raid device just hangs.

Hmm... How big are the components?  Is this error repeatable?  (just searching 
for more clues...)
> Am I doing something obviously wrong?

Nope.  (I just tried the above command on my test box, and it completed just 
fine... so this could be a bit entertaining to track down :-/ )


Greg Oster