Subject: Re: snap-19981207 crashes on mucho memory.
To: None <>
From: None <>
List: current-users
Date: 01/19/1999 18:22:06

I promised Liman that I'd send out a brief status update on this
one, and here it is, finally.

> I tried 1.3.2 release kernel, still on the 1.3 file system, and it
> runs, but behaves somewhat strangely.
> I run a _very_large_ "named" on this machine. Running 1.3.2 seemed to
> be OK at first. I started named. It grew up to its usual 530+
> MB. Suddenly I relized I couldn't do "ps" any more. It segmentation
> faulted. Same thing with "netstat", and the error messages gave me a
> _very_ strange clue that something was wrong with the file /netbsd,
> which both programs use to find where the structs are located in the
> running kernel. You can bet I was surprised to find bits and bytes
> from the DNS database in the file /netbsd. Something was severly
> broken.

This particular latter problem (apparent and probably also real
file corruption) turns out to be caused by kern/6332 (B_CACHE not
correctly maintained), which occurs in situations where the
buffer cache is relatively large (2822 buffers using 53M in this
case).  This bug eventually got resolved, and the bugfix is in
1.3.3.  The machine in question is now running 1.3.3 quite
happily with 1GB of RAM installed.

At about the same time we upgraded to 1.3.3 we also tried to run
a GENERIC kernel compiled from 5 Jan 1999 sources, but that one
still failed during initialization of UVM data structures with

(Copyright banner printed.)
kernel: page fault trap, code=0
Stopped in at _uvm_pageboot_alloc+0x9c:	movel  _PTmap(%ecx),%ebx

db> t
  at _uvm_pageboot_alloc+0x9c
  at _uvm_page_init+0x138
_uvm_init(f0358b18,f03fd010,3fd000,404000,3fd000) at _uvm_init+0x42
_main(0,0,0,0,0) at _main+0x2d

So, to conclude, 1.3.3 can apparently handle 1GB of memory on the
i386, but NetBSD-current cannot.  Unfortunately, it's beoynd me
to try to cook up a fix for this latter problem.


- Havard