Subject: some build problems ...
To: None <>
From: Robert V. Baron <>
List: current-users
Date: 01/15/1999 21:40:08
I tried a clean build from todays sources.  I ran into the
following problems, so far ...

1. etc/Makefile
       cd ${DESTDIR}; rm -f sys; ln -s usr/src/sys sys
sys is a directory. so this does not work.

2. sys/arch/i386/include/Makefile
	needs to include byte_swap.h

3. lib/libc
cc -O2 -DALL_STATE  -Wall -Wstrict-prototypes -Wmissing-prototypes -Wpointer-ar\
NT -I/usr1/src/lib/libc/include -D__DBINTERFACE_PRIVATE -DRESOLVSORT -I. -DPOSI\
X_MISTAKE -DFLOATING_POINT -nostdinc -idirafter /usr2/BSD/OBJ.0115/usr/include \
-c nslexer.c
cc1: warnings being treated as errors
nslexer.c: In function `_nsyylex':
nslexer.c:704: warning: label `find_rule' defined but not used
nslexer.c: At top level:
nslexer.c:1674: warning: `yy_flex_realloc' defined but not used
*** Error code 1

ld -x -shared  -o /usr1/src/gnu/lib/libobjc/    --whole-archive libobjc_pic.a --no-whole-archive   
ld: libobjc_pic.a: No such file or directory
In this case and the one below the .a exists in . and in DESTDIR, but ...

ld -x -shared  -o /usr1/src/gnu/lib/libstdc++/    --whole-archive libstdc++_pic.a --no-whole-archive /usr2/BSD/OBJ.0115/usr/lib/c++rt0.o  
ld: libstdc++_pic.a: No such file or directory

then the kernel, built today, hung, in X of course.