Subject: atapi lost interrupt
To: None <>
From: Johan Danielsson <>
List: current-users
Date: 01/15/1999 22:58:44
Content-Type: text/plain; charset=US-ASCII

On an Intel motherboard with a Mitsumi CD-R on the primary IDE

# disklabel cd0
pciide0:0:0: lost interrupt
	type atapi
	c_bcount: 32
	c_skip: 0
(repeats forever)

works fine in W98, as does connecting another CD-ROM. It makes no
difference if I use wdc instead of pciide.



Content-Type: text/plain; charset=US-ASCII

NetBSD 1.3I (BUOY) #1: Fri Jan 15 22:40:50 CET 1999
cpu0: family 6 model 1 step 7
cpu0: Intel Pentium Pro (686-class)
real mem  = 100270080
avail mem = 91164672
using 1249 buffers containing 5115904 bytes of memory
mainbus0 (root)
pci0 at mainbus0 bus 0: configuration mode 1
pci0: i/o enabled, memory enabled
pchb0 at pci0 dev 0 function 0
pchb0: Intel 82441FX PCI and Memory Controller (PMC) (rev. 0x02)
pcib0 at pci0 dev 7 function 0
pcib0: Intel 82371SB PCI-to-ISA Bridge (PIIX3) (rev. 0x01)
pciide0 at pci0 dev 7 function 1: Intel 82371SB IDE Interface (PIIX3)
pciide0: bus-master DMA support present
pciide0: primary channel wired to compatibility mode
atapibus0 at pciide0 channel 0
cd0 at atapibus0 drive 0: <CR-2801TE, , 1.07> type 5 cdrom removable
cd0: 32-bits data port
cd0: drive supports PIO mode 3, DMA mode 1
pciide0: secondary channel wired to compatibility mode
pciide0: secondary channel ignored (disabled)
cd0(pciide0:0:0): using PIO mode 0, DMA mode 1 (using DMA data transfers)
3Dfx Interactive product 0x0002 (video multimedia, revision 0x02) at pci0 dev 11 function 0 not configured
de0 at pci0 dev 15 function 0
de0: interrupting at irq 10
de0: 21140 [10-100Mb/s] pass 1.2
de0: address 00:00:1a:00:03:64
ncr0 at pci0 dev 17 function 0: ncr 53c875 fast20 wide scsi
ncr0: interrupting at irq 11
ncr0: minsync=12, maxsync=137, maxoffs=16, 128 dwords burst, large dma fifo
ncr0: single-ended, open drain IRQ driver, using on-chip SRAM
ncr0: restart (scsi reset).
scsibus0 at ncr0: 16 targets, 8 luns per target
sd0 at scsibus0 targ 0 lun 0: <DEC, RZ1CC-BA (C) DEC, 880F> SCSI2 0/direct fixed
sd0(ncr0:0:0): WIDE SCSI (16 bit) enabled
sd0(ncr0:0:0): 40.0 MB/s (50 ns, offset 16)
sd0: 4091MB, 3708 cyl, 20 head, 113 sec, 512 bytes/sect x 8380080 sectors
Texas Instruments product 0x3d07 (VGA display, revision 0x01) at pci0 dev 19 function 0 not configured
isa0 at pcib0
com0 at isa0 port 0x3f8-0x3ff irq 4: ns16550a, working fifo
com1 at isa0 port 0x2f8-0x2ff irq 3: ns16550a, working fifo
lpt0 at isa0 port 0x378-0x37b irq 7
wss0 at isa0 port 0x530-0x537 irq 5 drq 0 drq2 1: CS4231 or AD1845
audio0 at wss0
pcppi0 at isa0 port 0x61
sysbeep0 at pcppi0
npx0 at isa0 port 0xf0-0xff: using exception 16
vt0 at isa0 port 0x60-0x6f irq 1
vt0: generic, 80 col, color, 8 scr, mf2-kbd, [R3.32]
pms0 at vt0 irq 12
vt0: console
fdc0 at isa0 port 0x3f0-0x3f7 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB, 80 cyl, 2 head, 18 sec
biomask 4840 netmask 4c40 ttymask 5cc2