Subject: Re: NULL mounts not quite buff in -current?
To: Jonathan Stone <jonathan@DSG.Stanford.EDU>
From: Simon Burge <>
List: current-users
Date: 01/13/1999 13:12:43
On Tue, 12 Jan 1999 17:53:15 -0800  Jonathan Stone wrote:

> It seems to be strongly related to the pmap locking protocol, rather
> than the FS locking per se.
> The old 1.3.2 mips (which followed the Mach pmap conventions for
> setting dirty/reference bits) worked almost flawlessly with nullfs.
> (iirc, I built the 1.3 and 1.3.2 binary distributions in a
> nullfs-mounted directory).

I'm still not so sure.  Until last night, I'd not had a panic in my
1.3.1/i386, and that had /usr/src, /usr/obj, /usr/pkg and /usr/pkgsrc
all mounted by nullfs.

> Since updating the mips pmap to follow the (different) locking
> conventions required by UVM, the same nullfs bugs reported elsewhere
> appeared on a pmax.

The last time I tried on a pmax was 1.3E around May last year.  Looking
at the cvs logs, MACHINE_NEW_NONCONTIG and UVM support was added between
1.3 and 1.3E, as well as some other stuff.  I was still using the old VM
system around then.

I'll try really banging on a nullfs mount with my 1.3.3 box and see what