Subject: Kernel panics in -current
To: current-users <>
From: Bob Nestor <>
List: current-users
Date: 01/10/1999 09:05:48
I tried installing the very latest snapshot on my 68k Mac and the kernel 
crashed.  The installation was done on a clean disk, i.e. not an upgrade 
from an old installtion.  The binaries are dated 1/2/99 (kernel and 
userland) based on sources from 1/2/99. The X components are dated 
12/19/98.  Booting to single user works, but the kernel panics when going 
to multi-user.  Usually it's one of the system daemons that takes the 
system down, in this dump it was xdm.

xdmuvm_fault(0x155420, 0x3faf6000,0,0x1) -> 0x1
   type 8, code[mmu,,ssw]; 401074d
trap type 8, code=0x401074d, v=0x3faf600c
kernel progrram counter = 0xeb88e
kernel: MMU fault trap
pid = 134, pc = 000EB88E, ps = 2008, sfc = 1, dfc = 1

_Debugger(2004,8,2f060,809bc4,1374bc) + 6
_panic(1370bb,0,0,9,0) + 52
_trap(8,401074d,3faf600c) + 23c
faultstkadj(809d5c) + 0
_lookup(809edc) + 0
_namei(809edc) + 2e2
_vn_open(809edc,1,0) + 168
_sys_open(7e3138,809f88,809f80) + 7e
_syscall(5) + 14c
_trap0() + e

This panic and traceback is very similar to the panic I get trying to 
install and run the standard 1.3.3 release on the same system.  In that 
case it's usually PPP that brings the system down.  I know UVM has been 
thourghly checked out on all the ports, but I've never been able to get a 
system built with it to run reliably on my hardware. My system is a 33Mhz 
68030 with FPU and 20Meg of RAM.  Multiple disks, but this panic occured 
with only one disk configured and it has only three disk partitions - 
MacOS, NetBSD Root&Usr and NetBSD SWAP. The disk has been very reliable 
under NetBSD for years, and it has always worked with the NCR SCSI driver.

Does anyone have any ideas about what's happening here?  Any suggestions? 
 Need any more info?