Subject: Re: snap-19981207 crashes on mucho memory.
To: None <>
From: Lars-Johan Liman <>
List: current-users
Date: 12/18/1998 09:55:44
> Wow. That's bad.

My impression too. :-/

> You better send me some of that RAM.


> btw, you don't say whether it used to work and with what version?

I had 8 x 64 MB = 512 MB and 1.3 relase kernel. It had been up for
months without problems.

I replaced all SIMMs to 8 x 128 MB = 1,024 MB. 1.3 didn't work any
more, but crashed after a short while with "too much memory" in
cluster_rbuild. I had encountered this problem before, and Havard had
mentioned that something this or other had been fixed regarding
handling of much memory, so I thought I'd try the latest snap.

I tried the snap kernel mentioned above on the 1.3 file system with
the indicated result.

I tried 1.3.2 release kernel, still on the 1.3 file system, and it
runs, but behaves somewhat strangely.

I run a _very_large_ "named" on this machine. Running 1.3.2 seemed to
be OK at first. I started named. It grew up to its usual 530+
MB. Suddenly I relized I couldn't do "ps" any more. It segmentation
faulted. Same thing with "netstat", and the error messages gave me a
_very_ strange clue that something was wrong with the file /netbsd,
which both programs use to find where the structs are located in the
running kernel. You can bet I was surprised to find bits and bytes
from the DNS database in the file /netbsd. Something was severly

The machine is still up and running though. I have put in a fresh copy
of /netbsd in case it reboots. I just started named again for fun, and
will try to get to the machine later today to take out the memory and
move it to an identical test box which I have physical access to
(which I hardly have to the current one).

More info will follow when I get to test things properly.