Subject: IDE problems with snap-19981117a
To: None <>
From: Edwin Foo <efoo@MIT.EDU>
List: current-users
Date: 12/07/1998 01:47:44
Hi there,

I tried installing snap-1998117a last night after downloading from I ran into the same sysinst problems as the previous people
who tried installing off the boot floppy, so I installed using a 1.3.2
floppy and just gave it the new .tgz files instead. The machine boots at
first, but all disk accesses are now reporting lots and lots of soft errors
like the following:

wd0a: device fault writing fsbn 64848 of 64848-64863 (wd0 bn 6491): cn 64
to 6 sn 21), retrying
wd0: soft error (corrected)

(note, I'm typing this in off the console, so I might have mistyped)

_all_ disk accesses produce this error. The machine does still boot and get
to a login prompt, and I can log in, but everything stutters its way
through these errors.

Every once in a while, pciide also reports an error and times out for a bit
- something about an interrupt.

This is a kind of old machine -- a Pentium 133 with an Intel Zappa
motherboard. The hard disk in question is a Western Digital 1gb drive, not
EIDE. I've been wondering if the pciide changes made recently might have
anything to do with this, but I'm not sure. The machine was running 1.3.2
earlier without any problems.

If this problem is fixable, I'm going to need a kernel from someone -- this
is my only machine running NetBSD.

Edwin Foo

Edwin Foo        | MIT Computer Science - BS '98, MEng. '99     | Compaq Computer Corp. - Cambridge Research Lab
(617) 225-9715   | MIT Residential Computing Consultant (RCC) Developer
                 | MIT 6.270 Organizer -
       "Love must be sincere; Hate what is evil; cling to what is good."                       - Romans 12:9 <><