Subject: Re: large IDE disk (10GB) and -current
To: None <>
From: None <>
List: current-users
Date: 12/07/1998 03:58:02
> I just got a 10GB IDE drive and tried installing NetBSD on
> it. First I tried a 1.3.1 boot disk that I have - it wouldn't
> let me specify anything > 16383 for the number of cylinders,
> leaving me with only 8GB of my 10GB disk. Then I tried getting
> the boot disk (boot.fs) from the 981117a snapshot on
> - it boots, but then gives a segmentation fault
> early on because it says / is full.

Hm, yes, sysinst is core-dumping.  Unfortunately I have not been
able to debug this fully yet.  I just did a quick check, and it
seems that it's crashing in the match() routine.  Furthermore,
this looks suspiciously like the perror() problem I reported on
that I found in the 19981117 (original) snapshot, and which I
*think* was compiler related.  I will try to build a new
ramdiskbin from scratch and see if I can reproduce the problem,
and if I can't I'll roll out a new boot.fs image.  However, since
I'm currently travelling, don't expect it tomorrow...

If not, I'll probably re-sup and create another build; I seem to
remember that some fixe(s) have gone into egcs since Nov 17.

Oh, BTW, I've also seen that 1.3.2 can only deal with IDE disks
up to 8GB, but if you install the Bouyer IDE-DMA patches that
limitation was lifted by those patches (if I recall correctly).

- H=E5vard