Subject: large IDE disk (10GB) and -current
To: None <>
From: Laine Stump <>
List: current-users
Date: 12/05/1998 21:54:36
I just got a 10GB IDE drive and tried installing NetBSD on it. First I
tried a 1.3.1 boot disk that I have - it wouldn't let me specify anything >
16383 for the number of cylinders, leaving me with only 8GB of my 10GB
disk. Then I tried getting the boot disk (boot.fs) from the 981117a
snapshot on - it boots, but then gives a segmentation fault
early on because it says / is full.

Just now I tried a 1.3.2 boot disk, and it is similar to 1.3.1 - it says
that the "real" geometry of the disk is 16383 cylinders (when I know it to
be 19,885), and when I start entering in partition info, it tells me that I
have 16382 cylinders left (so I won't be able to get those last cylinders).

What have others done with large disks like this? Do I have any chance of
making it work with 1.3.1 (maybe by doing the disklabel by hand)? I'd
really rather not install anything different now, because I have that on a
local disk, while my net connection is temporarily down to a single 56k
modem (!!)

If you could CC your reply directly to me, that'd be real nice, since I
haven't yet resubscribed to all the mailing lists.