Subject: Re: Another changer, another changer problem
To: NetBSD-current Discussion List <email@example.com>
From: Greg A. Woods <firstname.lastname@example.org>
Date: 10/04/1998 17:04:33
[ On Sat, October 3, 1998 at 23:12:11 (-0700), Gandhi woulda smacked you wrote: ]
> Subject: Re: Another changer, another changer problem
> On Sat, 3 Oct 1998, Greg A. Woods wrote:
> * are good because there's at least 52 to play with.
> Yes, but the disklabel will only accommodate, what, twenty-two of them.
I only meant to point out that there are an adequate number of
single-letter suffixes to cover the maximum possible number of
partitions (i.e. the 22 that fit in a DEV_BSIZE block). There are not,
at least in Arabic decimal numbers represented in ASCII, enough
single-digit suffixes to cover the maximum possible number of
partitions, though indeed going to hexadecimal notation gets us double
what we have and much closer to the limit of 22.
> Rewriting the disklabel size would be a major hassle.
Oh, I wouldn't really want to do that -- at least not at the moment!
> Nah, not really. The theory behind something like disks is that if you
> can make it read-only, you can also make it read-write -- at least,
> that's how it'd be done in an intelligent manner.
You can often make disks read-only in the hardware realm. I think it
would be extremely useful to make *partitions* read-only in the driver
layer (vs. the filesystem layer where you can probably already do a
read-only mount for at least some filesystem types).
> But there again, the FS_* flags would be cool. For some reason, I thought
> such a thing existed.
Some exist in <sys/disklabel.h> (eg. FS_SWAP, FS_BOOT, FS_UNUSED, etc.),
but they're not used very much in ways that seem obvious, at least to
This is, of course, yet another swamp of confusing naming conventions.
I.e. there should really be separate namespace for partition flags and
filesystem type information. They could, for the moment, still be in
the same structure field, but I think it would be better to have
PT_BOOT, PT_RDONLY, PT_NOMOUNT, PT_UNUSED, PT_HASFS, PT_SWAP, etc. and
then just use FS_* to indicate the actual filsystem type.
Greg A. Woods
+1 416 218-0098 VE3TCP <email@example.com> <robohack!woods>
Planix, Inc. <firstname.lastname@example.org>; Secrets of the Weird <email@example.com>