Subject: Odd problem FTPing via nat/ppp?
To: None <>
From: William O Ferry <WOFerry+@CMU.EDU>
List: current-users
Date: 09/01/1998 17:57:54
    I recently moved, and have been working on getting my systems up. 
One machine has a modem and a static IP so it is set up for
demand-dialing PPP, and also running NAT for the other systems.  The
setup is working fine, with one exception.  There is one file that
consistantly fails to download, either via FTP or HTTP.  I was
eventually able to download it by FTPing it to another account I have,
gzipping it, then FTPing it to my local systems.  But it seems to me
that a certain data pattern must confuse PPP or NAT or something.  I
wanted to do a bit more experimenting and look into the contents of this
file before submitting a PR, but I was wondering if anybody else has
seen this, or if anybody else could try it and see if they also have the
problem.  With my current schedule it will probably be the weekend
before I can look into this, wanted to see if this problem was known or
if anybody else could reproduce it.  The dialup box is a combination of
1.3.2 binaries and -current (as of mid-June) kernel.

    The file is available at:

    If they happen to change this file anytime soon I can re-post the
one that fails somewhere.  I could not download the http or ftp version,
and tried the ftp version from a total of 3 ftp sites.  Clients included
NetBSD's /usr/bin/ftp, Netscape Navigator for 95/MacOS, and Windows ftp
(in MSDOS).  I tried both on internal hosts and on the dialup box itself
(don't know if this rules out NAT or not).  In all cases it froze up at
18824 bytes, IIRC.  tcpdump didn't show any farther packets related to
the transfer.  Other files have transfered with the same clients/servers
just fine.

    Thanks in advance.

                                                          Will Ferry

 William O Ferry  <woferry@CMU.EDU> | finger: woferry@Light.RES.CMU.EDU | talk:   finger for online status