Subject: Boot block oddness...
To: None <>
From: Mason Loring Bliss <>
List: current-users
Date: 08/31/1998 23:41:46
Hi, all. (This is pretty much i386-specific, FWIW, but it's definitely a
-current problem.)

I've never installed boot blocks before, and I thought I'd give it a whack.
I'd previously been using the stock 1.3.2 boot blocks on my -current system,
and I was using the old partition ID. Today I built a new kernel and a
new userland, and I thought I'd go whole hog and install new bootblocks with
the new partition ID and all that.


/user/mdec/installboot -v /usr/mdec/biosboot.sym /dev/rwd0a

failed... Or, rather, I got through it, but then had a system that wouldn't
boot. <cheer>

So, I did the same thing from a 1.3.2 boot floppy, putting the 1.3.2 boot
blocks back on, and it booted. Go figure.

Being rash and impulsive, I tried running /usr/mdec/installboot (the -current
version) from my /usr partition, and that failed, probably because it's built
under UVM and -current, etc. Dogged, I tried installing my -current boot
blocks using the 1.3.2 installboot. THAT worked, and gave me a bootable
set of -current boot blocks. I was able to change the partition ID and
reboot again without problems.

My questions:

1) Does anyone know why the -current (built today!) installboot fails? Is
it something I did, possibly?

2) Are there any inherent dangers in using a 1.3.2 installboot with a set
of -current boot blocks, as I did?

3) Can someone tell me how exactly I make a bootable floppy out of my
-current stuff? My guess is that I stamp an image from
/usr/src/distrib/i386/floppies/ onto a disk, and then install bootblocks as
I did above. Is this correct? If so, what's the proper way to stamp the
stuff onto a floppy?

Many thanks... :)

Mason Loring
"In the drowsy dark cave of the mind dreams build their nest with fragments
  dropped from day's caravan."--Rabindranath Tagore..awake ? sleep : dream;