Subject: ext2fs failures, but dump also failed
To: None <current-users@NetBSD.ORG>
From: Michael C. Richardson <>
List: current-users
Date: 07/29/1998 16:48:54
  I upgraded my desktop (XTERMinal) kernel to -current over the weekend.
(the ym0 driver works great, and all my CDROM woes went away once I replace
the Creative Labs CD with a no-namish 24x...)

  My sources are July 25th-ish sup.

  I noticed that my machine was locked up each morning, requiring a hard
boot (mouse frozen, virtual console didn't work). Turns out that it had
dropped into DDB. We need an option to force the DDB console to the fore
when it gets activated, I think.
  I was up tonight, so I hard the 2am /etc/daily. It froze. I tracked it
down to the sweep for core's. 
  For various reasons, my /var/tmp is a Linux ext2fs [OSBS won't boot
from an extended partition, so I made an non-extended partition, put lilo
on it, and told OSBS to boot that one. I have a better solution now...]

  The find seemed to trip up the lockmgr. I didn't write down the whole
trace dump: the lockmgr complained that it was trying to lock a structure
that was already locked. 
  I tried to get a panic dump, but I got a complaint from wddump about
being unable to recalibrate the drive and I didn't get a crash dump.
  I can reproduce this anytime, if you want me to do so. Here is my

  [in other news, I had to back out of the 1.3.2+ide patches on my
mail server and firewall. I'm back to 1.3_BETA. They kept crashing in
pmap_enter. My file server also continues to have twice weekly problems
in its NCR driver, usually during times of high activity, but sometimes
just randomly.]

NetBSD 1.3F (XTERM) #2: Sat Jul 25 19:26:58 EDT 1998
cpu0: Cyrix 6x86 (486-class)
real mem  = 33161216
avail mem = 28549120
using 430 buffers containing 1761280 bytes of memory
mainbus0 (root)
pci0 at mainbus0 bus 0: configuration mode 1
pci0: i/o enabled, memory enabled
VIA Technologies VT82C580 (Apollo VP) Host-PCI Bridge (host bridge, revision 0x23) at pci0 dev 0 function 0 not configured
pcib0 at pci0 dev 7 function 0
pcib0: VIA Technologies VT82C586 (Apollo VP) PCI-ISA Bridge (rev. 0x27)
VIA Technologies VT82C586 (Apollo VP) IDE Controller (IDE mass storage, interface 0x8a, revision 0x06) at pci0 dev 7 function 1 not configured
VIA Technologies VT83C572 USB Controller (USB serial bus, revision 0x02) at pci0 dev 7 function 2 not configured
ne2 at pci0 dev 9 function 0: Realtek 8029 Ethernet
ne2: Ethernet address 00:00:b4:58:92:db
ne2: interrupting at irq 10
Tseng Labs ET6000 (VGA display, revision 0x60) at pci0 dev 10 function 0 not configured
isa0 at pcib0
com0 at isa0 port 0x3f8-0x3ff irq 4: ns16550a, working fifo
com1 at isa0 port 0x2f8-0x2ff irq 3: ns16550a, working fifo
lpt0 at isa0 port 0x378-0x37b irq 7
lptprobe: mask ff data 55 failed
lptprobe: mask ff data 55 failed
wdc0 at isa0 port 0x1f0-0x1f7 irq 14
atapibus0 at wdc0
cd0 at atapibus0 drive 1: <BCD-24XHM CD-ROM, , VER 1.3> type 5 cdrom removable
wd0 at wdc0 drive 0: <FUJITSU MPA3017AT>
wd0: using 16-sector 16-bit pio transfers, lba mode
wd0: 1668MB, 3417976 sec, 512 bytes/sec
wdc1 at isa0 port 0x170-0x177 irq 15
atapibus1 at wdc1
npx0 at isa0 port 0xf0-0xff: using exception 16
vt0 at isa0 port 0x60-0x6f irq 1
vt0: et4000, 80/132 col, color, 8 scr, mf2-kbd, [R3.32]
vt0: console
fdc0 at isa0 port 0x3f0-0x3f7 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB, 80 cyl, 2 head, 18 sec
isapnp0 at isa0 port 0x279: read port 0x203
ym0 at isapnp0 port 0x220/16,0x530/8,0x388/8,0x330/2,0x370/2 irq 5 drq 0,1
ym0: OPL3-SA2 Sound Board : OPL3-SA3
audio0 at ym0
joy0 at isapnp0 port 0x201/1
joy0: OPL3-SA2 Sound Board 
joy0: joystick not connected
biomask c040 netmask c440 ttymask c4c2
boot device: wd0
root on wd0a dumps on wd0b
WARNING: old BSD partition ID!
mountroot: trying msdos...
mountroot: trying cd9660...
mountroot: trying nfs...
mountroot: trying ext2fs...
mountroot: trying ffs...
root file system type: ffs
init: copying out path `/sbin/init' 11