Subject: Re: Problems mounting filesystems - 1.3.2
To: None <current-users@NetBSD.ORG>
From: Gerald C. Simmons <>
List: current-users
Date: 07/15/1998 12:33:27
I think I found the source of the authentication problem. 

This resulted from more confusion with the new Sysinst program. When Sysinst
extracted 1.3.2 binaries, I first expected it to only extract base, comp,
text, etc, gnu, kern, etc., like it says in the INSTALL notes. However, it
also extracted all the X-stuff, unexpected. The secr.tgz file was also in this
directory, so I just assumed it was installed also.

WRONG! I check the dates of files like libcrypt.a May 22nd. Files in secr.tgz
are May 24th! Thank God for timestamps!

It doesn't look like domestic security stuff was installed,like I thought.

However, this brings up another question:

Q: How do you migrate a passwd/master.passwd file from 1.2.X to 1.3.2?

Here's what I did. After figuring out the Sysinst DID NOT migrate my passwd
files over from /etc.old, I cp'd master.passwd from /etc.old to /etc and
rebooted. This seemed to rebuild the passwd.db & spwd.db files. However, when
I tried to login - IT WORKED! If I had the exportable version of crypt, why
did all my old passwords work???

Any clues?

Gerry Simmons