To: None <>
From: Zdenek Salvet <>
List: current-users
Date: 07/14/1998 09:08:23

I have problem connecting the SMC EtherPower II (EPIC/100) card to
our oldish 10Mb hub. The output hangs and the driver reports
"epic0: device timeout". Diagnostic LEDs are in normal state (link=on,receive
blinking, 100mb=off,duplex=off).

I have tried to set 10Mb speed with

        bus_space_write_4(st, sh, EPIC_MMDATA, 0x2000);
        bus_space_write_4(st, sh, EPIC_MMCTL, MMCTL_WRITE);

in epic_init() but this worked only 2 times out of 6 attempts.
Trying to set various media with EZSTART.EXE makes no difference.
The card works fine with new 100Mb hub.

I use Jul 4 source tarball, the driver is
$NetBSD: smc83c170.c,v 1.1 1998/06/02 01:29:42 thorpej Exp $

If anybody has any suggestion how to make it work, please let me know.
Thanks in advance,
Zdenek Salvet                                     
           If God had meant for us to be in the Army,
         we would have been born with green, baggy skin.