Subject: pgksrc dependencies
To: None <current-users@NetBSD.ORG>
From: Simon J. Gerraty <>
List: current-users
Date: 06/20/1998 00:08:46
I thought I'd update my postgresql to 6.3.2 and use the pkgsrc tree to do
it. I just grabbed the latest pkgsrc.tar.gz from my local mirror.

Unfortunately pkgsrc/databases/postgresql/Makefile says postgresql
depends on tk80p2 - which I have never been able to download.

Ftp connects to ok and starts the transfer etc but
not a single byte ever hits my disk - it just sits there...

I know the problem is not me, as other auto fetches work fine.
This is the second package I struck which claims to require this
unobtainable archive - at least from the only listed site.

I've never used tk before when building postgres (never used tk
actualy), so I assume that it does not _really_ _require_ tk.... is
there someway to override the package in this regard?

Of course doing the old way is not a problem, I just thought it would
be cool to fit in with the new look and feel :-)

I hope downloading the precompiled tk8.0p2 will get it going.

BTW guys, the README.html stuff is very nice.  Thanks.