Subject: Re: pkg_* don't seem to work as advertised...
To: Not for internal consumption <>
From: Mark Andres <>
List: current-users
Date: 06/09/1998 06:29:58

On a maybe (un)related note, I have a problem with the qt package.  I
built it and it *does* appear in pkg_info.

  bongo% pkg_info | grep qt
  qt-1.33             A C++ X GUI toolkit.

I was also able to successfully build all the kde packages.  However, I
can not compile any other kde software that is not in the package system.
I have tried building korganizer, kpilot, and kppp.  In each case, as I
run the configure script, I get the following:

  checking for X... libraries /usr/X11R6/lib, headers /usr/X11R6/include
  checking for main in -lcompat... yes
  checking for main in -lcrypt... yes
  checking for the third argument of getsockname... int
  checking for socket in -lsocket... no
  checking for killpg in -lucb... no
  checking for QT... configure: error: QT-1.3 (headers and libraries) not
  found. Please check your installation! 

I can see that ldconfig has registered qt

  bongo% ldconfig -r | grep qt
          45:-lqt.1.33 => /usr/X11R6/lib/

The package system puts all the *.h file in /usr/X11R6/include/qt  Does
anyone have any idea where they "should" go for qt to be recogized outside
of the NetBSD package world?

Any help greatly appreciated.


On Sun, 7 Jun 1998, Not for internal consumption wrote:

> I'm running pkg_add on a slough of packages, and it doesn't seem to be doing
> the right thing.
>         PKG_TMPDIR doesn't seem to have any effect.
>         PKG_PATH doesn't seem to have any effect.
>         -t/some/other/staging/path, -t /some/other/staging/path don't seem
>         to have any effect.
> I tried to install qt-1.33, and while it says it's added, it doesn't show
> up with pkg_info, and any other packages which depend upon it don't register
> it as having been installed.

   Mark Andres               E-mail:
          Running NetBSD, 100% Microsoft Free!
   Me & NetBSD: