Subject: Reading tapes drives load average up
To: None <current-users@NetBSD.ORG>
From: D'Arcy J.M. Cain <>
List: current-users
Date: 04/21/1998 12:17:43
I am running a relatively current kernel (Apr 15) with an Archive
tape changer.  The tape is on a separate controller, an SC200.
The hard drives are on the Adaptec which is on board the Asus
T2P4S motherboard.  I was able to create a tape backup with no
problem but when I tried to verify it by doing a TOC the load
average went up to 10 and showed no signs of stopping its climb
when I killed the read.

The command I use to back up is this.

    exfind | pax -w -v -d -f /dev/tape

Note that /dev/tape is the same node as /dev/rst0.  The exfind program
simply spits out a list of files to back up.  This part seems to work
fine.  At the end of the backup it displays the message showing the
amount of data backed up and exits with no errors.  To verify I do the
following command.

    pax -v -f /dev/tape

I also tried it without the '-v' and either way it reads the tape
and displays the file names properly.  The load average, however,
starts climbing and I have to kill the verify.  Top shows that
programs other than pax are actually using the CPU.

A dmesg shows a bunch of these.

st0(ncr0:6:0):  Check Condition on opcode 0x8
    SENSE KEY:  No Additional Sense
                Incorrect Length Indicator Set
   INFO FIELD:  22016
     ASC/ASCQ:  No Additional Sense Information

And as I was writing this message, that system rebooted itself.  Well,
at least I can list the relevant startup messages.

ncr0 at pci0 dev 9 function 0: ncr 53c810a fast10 scsi
ncr0: interrupting at irq 12
ncr0: minsync=25, maxsync=206, maxoffs=8, 16 dwords burst, normal dma fifo
ncr0: single-ended, open drain IRQ driver
ncr0: restart (scsi reset).
scsibus0 at ncr0: 8 targets
st0 at scsibus0 targ 6 lun 0: <ARCHIVE, Python 28849-XXX, 4.98> SCSI2 1/sequential removable
st0: st0(ncr0:6:0): 5.0 MB/s (200 ns, offset 8)
density code 0x13, 512-byte blocks, write-enabled
ch0 at scsibus0 targ 6 lun 1: <ARCHIVE, Python 28849-XXX, 4.98> SCSI2 8/changer removable
ch0: 4 slots, 1 drive, 1 picker, 0 portals
ahc0 at pci0 dev 13 function 0
ahc0: interrupting at irq 11
ahc0: Using left over BIOS settings
ahc0: aic7880 Wide Channel, SCSI Id=7, 16 SCBs
scsibus1 at ahc0 channel 0: 16 targets
ahc0: target 0 synchronous at 10.0MHz, offset = 0xf
sd0 at scsibus1 targ 0 lun 0: <QUANTUM, XP32275W, LXY4> SCSI2 0/direct fixed
sd0: 2170MB, 5899 cyl, 5 head, 150 sec, 512 bytes/sect x 4445380 sectors
ahc0: target 1 synchronous at 10.0MHz, offset = 0xf
sd1 at scsibus1 targ 1 lun 0: <QUANTUM, VIKING 4.5 WSE, 8808> SCSI2 0/direct fixed
sd1: 4345MB, 6144 cyl, 8 head, 181 sec, 512 bytes/sect x 8899737 sectors

I also get these.

arpresolve: can't allocate llinfo
arpresolve: can't allocate llinfo
arpresolve: can't allocate llinfo
arpresolve: can't allocate llinfo
arpresolve: can't allocate llinfo
arpresolve: can't allocate llinfo
arpresolve: can't allocate llinfo

I don't think I was getting them before but I can't imagine how arp
could be related to this problem.

D'Arcy J.M. Cain <darcy@{druid|vex}.net>   |  Democracy is three wolves                |  and a sheep voting on
+1 416 424 2871     (DoD#0082)    (eNTP)   |  what's for dinner.