Subject: compiling egcs - problem with libgcc includes
To: None <current-users@NetBSD.ORG>
From: Thorsten Frueauf <>
List: current-users
Date: 04/10/1998 11:17:17

I tried to compile egcs with doing what Todd suggested in his mail
(on NetBSD/i386 current). I came to the point where I wanted to
rebuild egcs/libgcc and I started with `make includes` and got
the following:

[frueauf@cyberlap]/src/gnu/usr.bin/egcs/libgcc# make includes
c++ -O  -Werror -I/src/gnu/usr.bin/egcs/libgcc/../../../dist/gcc/cp/inc -I/src/
gnu/usr.bin/egcs/libgcc  -I/src/gnu/usr.bin/egcs/libgcc/../common -I/usr/src/gn
u/usr.bin/egcs/common/obj  -I/src/gnu/usr.bin/egcs/libgcc/../arch -I/src/gnu/us
r.bin/egcs/libgcc/../arch/i386 -I/src/gnu/usr.bin/egcs/libgcc/../../../dist/gcc
  -I/src/gnu/usr.bin/egcs/libgcc/../../../dist/gcc/config -I/src/gnu/usr.bin/eg
cs/libgcc/../../../dist/gcc/config/i386 -DMD_EXEC_PREFIX=\"/usr/libexec/\"  -DM
ION=\"egcs-2.90.27\"  -DDEFAULT_TARGET_MACHINE=\"i386-netbsd\"  -o /src/gnu/usr.
bin/egcs/libgcc/../../../dist/gcc/cp/inc/new /src/gnu/usr.bin/egcs/libgcc/../../
/usr/lib/crt0.o: Undefined symbol `_main' referenced from text segment
*** Error code 1

A normal `make` build the libgcc and I could install it too. But if I
try to make build from /src I get the same error again at this point.
So whats my fault and how to fix it?

Thanx for any suggestions in advance!


   Name  : Thorsten Frueauf            Milano@irc cri@onaliM       //
   E-Mail: oder     \X/