Subject: Re: CD-R with NetBSD-1.3?
To: Chris Jones <>
From: Brian Buhrow <>
List: current-users
Date: 01/12/1998 15:32:19
		I believe cdrecord has its own SCSI level driver, so as long as you
can expose the SCSI layer to cdrecord, it should work.  This should be true
whether or not the device shows up as a cd or as uk.  The advantage of
having it show up as a cd is that you can use the cd driver to actually
read from the cds you burn rather than having to switch them to another cd
player to test them. 
	My Sony 920S shows up as device type 4 which I guess is WORM.  Since
the cd driver doesn't recognize this type of device as something it can
drive, the subsystem doesn't assign it to the cd driver.  Thus, I get uk0
at  target 5 lun 0.
	For ease of use with cdrecord, I symlink /dev/scgx to /dev/uk0.  I
suspect that if this thing showed up as a cd, I could symlink /dev/scgx to
/dev/cdxa and it would work.  Incidentally, I burned my first cd last night
on  the Sony with cdrecord 1.6, NetBSD 1.2G and the uk device.  It worked
	I suspect your problem is some timing incompatibility between the SCSI
CD-R driver inside cdrecord and your actual device.  Is it possible that
the device you have is a different revision than the one used to develop
the driver?

On Jan 12,  3:14pm, Chris Jones wrote:
} Subject: Re: CD-R with NetBSD-1.3?
} On Sat, 10 Jan 1998, Dave Burgess wrote:
} > My Sony CD writer will not write a CD if it is connected as a 'cd'
} > drive.  It will only work as a 'uk' drive.  I also had to install it as
} > a WORM drive.  When I last looked at it (two months ago), the SCSI/ATAPI
} > subsystem wasn't ready to do writable CD-ROMs....
} > 
} > uk0 at scsibus0 targ 2 lun 0: <SONY, CD-R   CDU926S, 1.1f> SCSI2 4/worm removable
} > uk0: unknown device
} Still no luck.  It now ID's as:
} uk0 at scsibus0 targ 2 lun 0: <HP, C4324/C4325, 1.27> SCSI2 5/cdrom removable
} uk0: unknown device
} I know this drive works, because my friend made it work on a FreeBSD
} system.  I know my SCSI controller works, because I've been using a tape
} drive on it.
} When you say you had to install it as a WORM drive, what exactly do you
} mean?  I noticed that your flags are 4 instead of 5; is that it?  If so,
} how does one go about changing this?  Is it device-specific?
} Chris
} -------------------------------------------------------------------------------
} Chris Jones                            
}            Mad scientist in training...
} "Is this going to be a stand-up programming session, sir, or another bug hunt?"
>-- End of excerpt from Chris Jones