Subject: Strange problem with Ultrastore 34F
To: None <current-users@NetBSD.ORG>
From: Dave Burgess <>
List: current-users
Date: 11/25/1997 00:18:26
I can't tell if this is a driver problem, or a hardware problem.

1)  Things attached to the SCSI bus don't seem to always work correctly.

	a)  The tape drive has decided to not back up any files under a
	version of Amanda that has worked flawlessly for almost six
	months.  The error on the system log is one about "unable to get
	size".  It's almost like an ioctl went away during the
	ATAPI/SCSI combination.

	b)  The CD-R will not write a CD - I can get into specifics
	later, but right now, the problem is the ASC/ASCQ set is
	0x89/0x00.  I've sent an E-Mail to Sony to get this vendor
	specific ASC, but the drive and 'cdrecord' are reported to work
	together in 1.2.  

	c)  The 'parent' directory or the 'current' directory will
	sometimes disappear.  Using 'cd' to change to a known directory
	will work, after which point the problem is not reproducable.
	This only happens on sd0.  None of the IDE drives ever exhibit
	this behavior.

	d)  Some of my CD-ROM drives will just disappear.  They will
	probe OK, but once I try to access them, either the files on the
	drive aren't there, or the drive will suddenly stop working and
	the mount point will become a 'regular file'.  After I reboot,
	they might work fine the next couple of times.

2)  The latest kernel will not recognize the 'uha' card when a kernel
from a week ago will.  I deleted the libraries and the destination
directory for the kernel build, and it doesn't help.  Even COLD booting
the system (which would work if the card were in an 'indeterminate state'
yielded nothing.

3)  I've not been able to get a 'known working' Adaptec 1542 to work in
the machine in several weeks.  I tried to get it working the other
night, but it fails the probe for the drives.

I've checked termination on the SCSI chain, and tried reducing the drive
count (from 6 to 3) to see if the SCSI bus was overloaded.  Neither of
those yielded any positive results.  I only have the one Ultrastor, or
I'd try replacing that.

I have SCSI verbose turned on, but I have yet to be able to figure out
any more from the output than I knew before.

Any suggestions???
Dave Burgess                   Network Engineer - Nebraska On-Ramp, Inc.
*bsd FAQ Maintainer / SysAdmin for the NetBSD system in my spare bedroom
"Just because something is stupid doesn't mean there isn't someone that 
doesn't want to do it...."