Subject: Errors building libc on m68k/amiga
To: Current NetBSD <current-users@NetBSD.ORG>
From: Eric Delcamp <>
List: current-users
Date: 11/15/1997 23:40:31

Due to some difficulties to upgrade from 1.2 to 1.3 with the Amiga port (to
build libc for example), I have made a cross compiler on my i386 box (with
binutils-2.8.1 and gcc-
All work fine if I try to build a kernel (thanks to Dave Huang
<>). Maybe not the simplest solution ;-))
But the kernel is just a test, and I want to build libc now.
And then, same error than on the amiga :

m68-gcc -O -Werror -Wall -Wstrict-prototypes -Wmissing-prototypes -Wpointer-
-idirafter /local/m68k/usr/include -c -fpic -DPIC
/usr/src/lib/libc/db/hash/hash_bigkey.c -o
/var/tmp/cc14716a.s: Assembler messages:
/var/tmp/cc14716a.s:753: Error: operands mismatch -- statement 'jbsr
_collect_data,a1' ignored
/var/tmp/cc14716a.s:891 Error: operands mismatch -- statement 'jbsr
_collect_data,a1' ignored
*** Error code 1

Same error on the Amiga side, but not with the same file (__fts13.c &
jbsr <address>,a1 is not a standard m68k instruction.
NetBSD/gas don't work.

Any hints ?