Subject: Re: Trouble with latest tcp fixes on pmax. Any others?
To: Jason Thorpe <>
From: Jonathan Stone <jonathan@DSG.Stanford.EDU>
List: current-users
Date: 11/14/1997 01:41:28
On  Fri, 14 Nov 1997 00:33:57 -0800,,
  Jason Thorpe <> writes:

>On Thu, 13 Nov 1997 21:08:45 -0800 
> Jonathan Stone <jonathan@DSG.Stanford.EDU> wrote:
> > I just built a pmax kernel from the latest sup source, with
> > the updated tcp_subr.c.
>...I'm assuming you got the rest of the tcp changes that went in a couple
>of days ago.  The last change to tcp_subr.c simply removed an extra
>call to rtfree(), and would only have made a difference of PMTU
>discovery is enabled.

Yes, that's the one.  Rebuilding after supping the new tcp_subr.c gave
a kernel that crashed.  I tried recompiling; same thing.

>> > Has anyone tried or tested the latest TCP code on, say, a machine
>> > requiring aligned addresses? Did it work?
>>TCP is working Fine on my SS2 and AlphaStations.  Source base is "today".

Hmpf. Meanwhile, I nuked the updated tcp files, resupped with -o,
reinstalled comp.tar.gz from a snapshot I built yesterday, recompiled,
and it went away.  Weird.  I'm guessing this is weirdness in a local,
non-NetBSD NFS server; it wouldn't be the first time that's happened.

Sorry for the false alarm; thanks for  the help, jason.