Subject: more st wierdness
To: None <>
From: Rafal Boni <>
List: current-users
Date: 11/07/1997 22:37:31
Seeing all these messages about st.c reminds me of a problem I have on my 
machine... Basically, 9/10 tape dumps die unexpectedly (it looks like the
tape drive may have taken offense to something the SCSI code said and tries
to reset itself??).

My machine info: (abbreviated)

NetBSD 1.3_ALPHA (DOPPELGANGER) #0: Tue Oct 28 14:16:16 EST 1997
cpu0: family 5 model 2 step 6
cpu0: Intel Pentium (P54C) (586-class)
real mem  = 33157120
avail mem = 29179904
using 430 buffers containing 1761280 bytes of memory
mainbus0 (root)
isa0 at pcib0
aic0 at isa0 port 0x340-0x35f irq 11	[this is a Compaq AIC-6260 card]
scsibus0 at aic0: 8 targets
sd0 at scsibus0 targ 0 lun 0: <FUJITSU, M1606S-512, 6226> SCSI2 0/direct fixed
sd0: 1041MB, 3457 cyl, 6 head, 102 sec, 512 bytes/sect x 2131992 sectors
st0 at scsibus0 targ 3 lun 0: <EXABYTE, EXB-85058SQANXR1, 06S1> SCSI2 1/sequential removable
st0: density code 0x0, 1024-byte blocks, write-enabled

The problem: 
I try and dump some partition to the tape, after some time all the drive 
lights on the exabyte go on, the tape rewinds after some thought, and dump
is either convinced that the tape's ended or sits frozen in D+ state. I
*know* the tape's not done (even a 500Meg partition should fit easily
on a compressed 112m 8mm tape), since all the partitions I've tried have
been fairly small (vs. tape size).

I just tried this, and dump actually got 95% done (which is more than I
usually get), before the "tape lights all go on, tape rewinds, dump asks
for another tape" happened.  Here's the messages from the tail of the 
kernel message buffer:

st0(aic0:3:0):  Check Condition on opcode 0x0
    SENSE KEY:  Unit Attention
     ASC/ASCQ:  Power On, Reset, or Bus Device Reset Occurred

st0(aic0:3:0):  Check Condition on opcode 0x0
    SENSE KEY:  Not Ready
     ASC/ASCQ:  Logical Unit Is in Process Of Becoming Ready

[...above repeated five or six times...]

Occasionally, I've also seen "st0(aic0:3:0) timed out" and a few days
ago I saw some really scary looking message from aic0:3:0 (something
about some unexpected SCSI transition), which unfortunately I can't find
in my logs.

Any ideas appreciated.

Rafal Boni