Subject: Re: AIC7XXX driver - No Tape support for writing?
To: Gerald C. Simmons <>
From: Jason Thorpe <>
List: current-users
Date: 11/07/1997 10:34:14
On Thu, 6 Nov 1997 09:15:42 -0800 (PST) 
 "Gerald C. Simmons" <> wrote:

 > I've done some further investigating and I'm suspecting there is no "write
 > support" in the Adaptec AIC7XXX drivers, or at least the 2842VL.

Um, how can there possibly be "no write support"?

 > I tried the following:  "tar cvf /dev/st0 <directory>" with my Archive 150
 > attached to an AHA2842VL controller. The Tape LED came on, tar went about it's
 > business with NO ERRORS, but the drive NEVER made a move. It was as if tar was
 > dumping to /dev/null.
 > I checked all the -current files for the AIC7XXX and ahc_isa.c drivers for any
 > changes since 1.2.1. There were only context changes - bus_space vs. bus_io.
 > Does anyone know if this is a known missing feature?

The "ahc" driver doesn't know (or care) what type of device its talking
to.  That's be beauty of SCSI :-)  Also, if the ISA "ahc" couldn't write
to tapes, it would be a problem for the EISA and PCI "ahc" drivers, too,
since it's really all the same driver.

 > I can READ from tapes, just can't write!

I suspect it's an artifact of not using the "raw" tape.  Try using /dev/rst0.

The block device interface to tapes hasn't really ever worked (the semantics
of implementing it are just too hairy, for one), and probably ought to just
be removed.

Jason R. Thorpe                             
NASA Ames Research Center                            Home: +1 408 866 1912
NAS: M/S 258-6                                       Work: +1 650 604 0935
Moffett Field, CA 94035                             Pager: +1 415 428 6939