Subject: Re: Problems with 1.3-ALPHA (fwd)
To: Erik E. Fair <>
From: Rob Deker <>
List: current-users
Date: 11/05/1997 22:52:01
On Wed, 5 Nov 1997, Erik E. Fair wrote:

you know, since all this came up, i tried 1.3 from the 10/29 snapshot today.
On an SS2 here, I had an older sparc snapshot running and I simply dropped
the 1.3 kernel in and attempted to boot so that I could untar the new 1.3
stuff. All booted well, etc, until (in single user mode) I tried to mount
local filesystems. mount -vat ffs yielded the following:

#mount -vat ffs 
ffs: /dev/sd0a on /: specified device does not match mounted device
fss: /dev/sd0d on /var: Device not configured
/dev/sd0g on /usr type ffs (local)
/dev/sd0h on /local type ffs (local)

running mount at this point yields:

root_device on / type ffs (local, read-only)
/dev/sd0g on /usr type ffs (local)
/dev/sd0h on /local type ffs (local)

fstab looks like:

/dev/sd0a / ffs rw 1 2
/dev/sd0d /var ffs rw 1 2 
/dev/sd0g /usr ffs rw 1 2
/dev/sd0h /local ffs rw 1 2

any ideas?

> Simple rule for all NetBSD upgrades:
> a new kernel can run old binaries (with the appropriate COMPAT options),
> but an old kernel cannot run new binaries.
> Therefore, always boot a new kernel, first.
> 	Erik <>

"Off the keyboard, through the CPU, | 
out the transceiver, down the rj45  | Technical Operations Manager
line, across the router, through    | 
the Hub, out the gateway.           |  
        Nothing but net."           |