Subject: SOLVED - Re: current build problem on pmax, sources from 11/1
To: None <>
From: maximum entropy <>
List: current-users
Date: 11/05/1997 07:00:22
>From: maximum entropy <>
>>From: Jonathan Stone <jonathan@DSG.Stanford.EDU>
>>> From: maximum entropy <>
>>> While running a "make build" on pmax:
>>> ===> readline
>>> [tputs and other warning errors]]
>>I have never seen these, and I'm unable to reproduce them.  I tried
>>again just now and I still don't see these.  I don't see the warnings
>>at all, and I triple-checked I'm compiling with -Werror.
>> [...]
>>Could Mr. entropy check that the termcap.h in his build tree
>It's possible that some other file on my system didn't sup properly.
>I will sup today's sources and try again.

I tried resupping and it didn't help.  I tried building on my i386
box, and it worked.

I compared the source trees between the two machines, and the relevant
difference is that my pmax had a /usr/src/gnu/dist/readline/config.h
while the i386 did not.  This makes sense, because I had run
/usr/src/gnu/dist/configure a few days ago on the pmax, whie
experimenting with different versions of the pmax toolchain.  After I
rmed /usr/src/gnu/dist/*/config.h the problem went away.

The parts of the tree that are building from /usr/src/gnu/dist
probably ought to have '-I.' prepended to their CFLAGS to prevent this
sort of weirdness from showing up.

The definition of _rl_output_character_function really does conflict
with parameter 3 of our tputs() prototype.  This isn't noticable in
the "normal" case because no tputs() prototype is in scope.
/usr/src/gnu/lib/readline/config.h does NOT define HAVE_TERMCAP_H.


entropy -- it's not just a good idea, it's the second law.