Subject: Re: Problems with 1.3-ALPHA
To: Mark Andres <>
From: Erik Bertelsen <>
List: current-users
Date: 11/05/1997 09:44:02
If you did not install a 1.3_ALPHA kernel before doing this, I'd expect
results like this.

Try to boot from a 1.3_ALPHA kernel (shold be part of the snapshot) --
you may place the kernel on your MacOS file system and boot from it.
Hopefully this will recover your system.

In general a newer kernel with backwards compatibility may be used
with older user land binaries while upgrading, while the newer
user land applications might not work with an old kernel. In the
actual case with upgrading from 1.2.1 to 1.3_ALPHA, this actually
explains that e.g. reboot and halt do not work.

- Erik

On Tue, 4 Nov 1997, Mark Andres wrote:

.. I am using a Macintosh IIcx with 20MB of RAM, a 730MB Quantum HD, and was
.. previosuly running 1.2.1.  I downloaded the 1.3-ALPHA snapshot for the
.. mac68k port. I am now in the process of installing it.  I am following the
.. same procedure I used to upgrade from 1.2 to 1.2.1.  Namely,
.. I booted single user and mounted my partitions read/write.
.. I went to the root directory ( cd / ) and then did
..    tar --unlink -zxvpf base.tar.gz
.. This was the base snapshot for 1.3-ALPHA.  Tar did its stuff and seemed to
.. untar everything without any problems.  However, now I cannot use any
.. commands.  All commands come up with the same error message:
..   Bad system call - core dumped
.. I tried 'ls', 'tar', 'cat', even 'halt' and 'shutdown' do not work.  At
.. this point, I am wide open to suggestions, since I cannot even shutdown my
.. system.