Subject: Re: Problems with 1.3-ALPHA
To: Mark Andres <>
From: Bill Studenmund <>
List: current-users
Date: 11/04/1997 17:23:23
> Hi,
> I am using a Macintosh IIcx with 20MB of RAM, a 730MB Quantum HD, and was
> previosuly running 1.2.1.  I downloaded the 1.3-ALPHA snapshot for the
> mac68k port. I am now in the process of installing it.  I am following the
> same procedure I used to upgrade from 1.2 to 1.2.1.  Namely,
> I booted single user and mounted my partitions read/write.
> I went to the root directory ( cd / ) and then did
>    tar --unlink -zxvpf base.tar.gz
> This was the base snapshot for 1.3-ALPHA.  Tar did its stuff and seemed to
> untar everything without any problems.  However, now I cannot use any
> commands.  All commands come up with the same error message:
>   Bad system call - core dumped
> I tried 'ls', 'tar', 'cat', even 'halt' and 'shutdown' do not work.  At
> this point, I am wide open to suggestions, since I cannot even shutdown my
> system. 

I've run into this problem before. I'm not exactly sure what I did, but
there are a few things you could try.

Wait. Are you running a 1.3_ALPHA kernel? If not, you will loose horidly.
BAD things happen if the kernel is versions behind the binaries.

If you're running a 1.3 kernel, drop into the debugger, and then

call cpu_reboot(0,0)

in the debugger. That will shut things down after syncing the disks.

Another option would be to just log out. I think the time I ran into this
problem, the main thing was that my current shell was sick. re-forking
my login shell got things set up right enogh that all was well.

Take care,