Subject: Re: Problems with 1.3-ALPHA
To: Mark Andres <>
From: Colin Wood <>
List: current-users
Date: 11/04/1997 15:33:58
Mark Andres wrote:
> Hi,
> I am using a Macintosh IIcx with 20MB of RAM, a 730MB Quantum HD, and was
> previosuly running 1.2.1.  I downloaded the 1.3-ALPHA snapshot for the
> mac68k port. I am now in the process of installing it.  I am following the
> same procedure I used to upgrade from 1.2 to 1.2.1.  Namely,
> I booted single user and mounted my partitions read/write.
> I went to the root directory ( cd / ) and then did
>    tar --unlink -zxvpf base.tar.gz
> This was the base snapshot for 1.3-ALPHA.  Tar did its stuff and seemed to
> untar everything without any problems.  However, now I cannot use any
> commands.  All commands come up with the same error message:
>   Bad system call - core dumped
> I tried 'ls', 'tar', 'cat', even 'halt' and 'shutdown' do not work.  At
> this point, I am wide open to suggestions, since I cannot even shutdown my
> system. 

You'll have to manually reboot the machine...but the problem is that you
need to upgrade the kernel first.  What has happened is that all of the
syscall numbers have changed from 1.2 to 1.3 (well, many of them), so the
newer binaries cannot interface with the older kernel.  Once you install a
1.3 kernel, everything should be just fine.

I hope this helps.


Colin Wood                       
Component Design Engineer - MD6                 Intel Corporation
I speak only on my own behalf, not for my employer.