Subject: NFS Server goes down freezes the client
To: None <current-users@NetBSD.ORG>
From: Rick Byers <>
List: current-users
Date: 10/31/1997 10:14:01
If I mount an nfs server, and then for some reason, that server goes down
- I get stuck.  Any requests just sit there and don't appear to timeout.
Eventually I get a message saying that the nfs server isn't responding,
but it still doesn't timeout and abort.  IMHO, there should be some way to
unmount an nfs mount when the nfs server stops responding.  A ps shows my
'ls' process as being in disk - and I cannot kill it (kill -KILL doesn't
do the trick either).  I've tried using the -s (soft mount) option to
mount_nfs, but that doesn't seem to help either (even with -x 1).  IMHO
anything non-critical in the outside world, should not be able to cause
the system to freeze.  Who knows when something's going to happen on the
ethernet for a mount that you don't even need.

Also, is there any way for amd to mount sub-directories on top of other
mounts?  I.E., I want to mount remote:/ on /remote, and remote:/usr on
/remote/usr.  When I setup the map file for this, access to /remote/usr
just returned empty - presumably because it's now a symlink to the private
mount point handled directly by NFS, not the point handled by amd.  I
guess I could use null mounts to acheive it, but there should be a better
way (since amd seems extremely powerfull).


Rick Byers                                      Internet Access Worldwide                                		     System Admin
University of Waterloo, Computer Science                    (905)714-1400