Subject: Re: a few more questions about 1.3_ALPHA
To: Mika Nystrom <>
From: Bill Studenmund <>
List: current-users
Date: 10/28/1997 09:43:03
On Tue, 28 Oct 1997, Mika Nystrom wrote:

>     I have stumbled into a couple of strange issues that I am wondering if
> someone in NetBSD-land knows anything about.  First, there's some odd 
> behavior I noticed when dialing into one of my systems from a Wyse 75
> through a 14.4 modem to a Xyplex and then via telnet to the NetBSD machine.
> Now, this has always worked great for me under 1.1 and 1.2, but the 
> 1.3 system shows a strange anomaly: basically every time I type return
> I get a ^@ character inserted after the line feed.  This only happens from
> the Xyplex, and it only happens using telnet (not rlogin).  It's not a 
> critical bug in any sense since there are such simple workarounds,
> but I found it annoying and tried a few things, none of which had any
> effect: recompiling with 4.2 TCP compatibility turned on, replacing
> all the binaries for telnetd, inetd, login with the 1.2 binaries, fiddling
> terminal types... any ideas what might be going on?  (I'd try to debug
> using tcpdump, but it's pretty painful given that the terminal is nowhere
> near any other terminal or X display and I have to dial into the Xyplex
> with a modem...)

I'm seeing the same thing, under certain circumstances. I have a PowerMac
running Stanford's kerberized telnet program. If I telnet directly to a
486 running NetBSD, I get a kerberized connection, and I see the exact
thing you see above, a ^@ after every line. What's annoying is that I
think the telnetd is inserting it into the received data stream, and
passing to to the shell or running program. It makes using elm imposable
(to the extent it's possable at all :-)

The really weird thing is that if I use the same mac to telnet to an
RS/6000 running AIX 3.2.5 or a SPARC station running Solaris something and
THEN telnet to the NetBSD box, I don't have this problem. Even with
totally kerberized connections!

The terminal settings end up being the same, so I don't think it's a
termcap thing.

I guess it's something to do w/ the telnet negotiation. Does someone have
any ideas?

Take care,