Subject: a few more questions about 1.3_ALPHA
To: None <current-users@NetBSD.ORG>
From: Mika Nystrom <>
List: current-users
Date: 10/28/1997 01:15:19
Hello again everyone,
    First of all I'd like to thank all those who responded to my pleas for
help with NFS (especially Frank).  My systems are now using -noresvport
in exports and everything is happy... almost!

    I have stumbled into a couple of strange issues that I am wondering if
someone in NetBSD-land knows anything about.  First, there's some odd 
behavior I noticed when dialing into one of my systems from a Wyse 75
through a 14.4 modem to a Xyplex and then via telnet to the NetBSD machine.
Now, this has always worked great for me under 1.1 and 1.2, but the 
1.3 system shows a strange anomaly: basically every time I type return
I get a ^@ character inserted after the line feed.  This only happens from
the Xyplex, and it only happens using telnet (not rlogin).  It's not a 
critical bug in any sense since there are such simple workarounds,
but I found it annoying and tried a few things, none of which had any
effect: recompiling with 4.2 TCP compatibility turned on, replacing
all the binaries for telnetd, inetd, login with the 1.2 binaries, fiddling
terminal types... any ideas what might be going on?  (I'd try to debug
using tcpdump, but it's pretty painful given that the terminal is nowhere
near any other terminal or X display and I have to dial into the Xyplex
with a modem...)

    The other thing I ran into concerns using serial consoles.  I really
like the new biosboot that detects memory sizes > 64MB correctly (since
none of our new systems has 64 MB or less!)  But I can't find a shred
of documentation anywhere that tells me how to tell it to use a serial
console.  I looked in the source and found a few interesting cpp #defines
and tried a bunch of them, but none of my attempts was successful.  Also,
the old thing I have in the headless kernel configs doesn't seem to work
with the 1.3_ALPHA kernel...????

options         COMCONSOLE=0
options         CONADDR=0x3f8
options         CONUNIT=0
options         CONSPEED=9600


If anyone has any ideas about these things, please let me know!

     Mika <>
     Department of Computer Science
     California Institute of Technology
     Pasadena, Calif., U.S.A.