Subject: Re: Problems with compiling GENERIC of yesterday (i386)
To: Kjetil B. Thomassen <>
From: Bill Studenmund <>
List: current-users
Date: 10/27/1997 13:07:01
On Mon, 27 Oct 1997, Kjetil B. Thomassen wrote:

> Yesterday I resuped the whole lot, and tried to make myself a kernel
> for my Compaq LTE 5200.
> That didn't work, so I tried to compile the GENERIC kernel, but that
> gave me the same warnings.
> The first problem occured in make depend, and that is the same message
> I got when I tried to make it afterwards:
> depending the kern library objects
> depending the compat library objects
> mkdep -x assembler-with-cpp -traditional-cpp -D_LOCORE -I. -I../../../../arch -I../../../.. -nostdinc -DEXEC_AOUT -DEXEC_SCRIPT -DI386_CPU -DI486_CPU -DI586_CPU -DI686_CPU -DMATH_EMULATE -DUSER_LDT -DXSERVER -DUCONSOLE -DINSECURE -DKTRACE
> ../../../../arch/i386/i386/locore.s:1450: empty #if expression
> ../../../../arch/i386/i386/locore.s:1450: unterminated `#if' conditional

Make sure you have version 1.172, which is the latest. With your defines
above, the #ifdef in that area should be fine.

Take care,