Subject: Re: mit-pthreads and C++
To: None <current-users@NetBSD.ORG>
From: Gary D. Duzan <>
List: current-users
Date: 10/26/1997 15:45:43
In Message <> ,
   "Gary D. Duzan" <> wrote:

=>   I've been attempting to get OmniORB, which requires pthreads,
=>running on NetBSD. While I can eventually manage to get everything
=>to compile, when I run it I don't get anything that is sent to cerr
=>for output.  If I put in an fprintf, I get the output fine. I've
=>tried any number of link options and library orderings, but nothing
=>makes it work. I fear this is just a symptom of a deeper problem.
=>   Has anyone else tried this and had similar results? Thanks.
=>                                      Gary D. Duzan
=>                         Humble Practitioner of the Computing Arts

   Sorry, I forgot the details.

NetBSD 1.3_ALPHA NetBSD 1.3_ALPHA (WHEEL) #0: Sat Oct 25 15:36:37 EDT 1997 i386

I'm using the pkgsrc/devel/mit-pthreads version.
When I put a 'cerr << "foo" << endl;' at the beginning of main(), I
still don't get anything. My current theory is that the constructor
for cerr isn't getting called, which makes be wonder if any static
constructors are getting called.

                                      Gary D. Duzan
                         Humble Practitioner of the Computing Arts