Subject: Re: SVR4 compat: can't get current directory?
To: Todd Vierling <>
From: Frank van der Linden <>
List: current-users
Date: 10/25/1997 23:31:35
On Sat, Oct 25, 1997 at 11:47:41AM -0400, Todd Vierling wrote:
> On sparc -current as of yesterday, using Solaris 2.5.1 libs and bins under
> SVR4 compat, many programs are failing with a "can't get current directory" 
> error.  I even tried the /usr/bin/pwd program which returns the same error
> and a partial ktrace (starting right after loading of shared libraries) is
> attached below.  The pwd does _not_ fail when cwd = /, but it fails in any
> other directory.  I don't know how long it has been like this as I haven't
> been using SVR4 compat lately. 

>    319 pwd      CALL  getdents(0x3,0x212b8,0x418)
>    319 pwd      RET   getdents 0

This is probably your problem. Please make sure you have an up-to-date
compat/svr4/svr4_misc.c, and possibly, if you're running on an NFS filesystem,
sys/nfs/nfs_bio.c. Both have, over the past few weeks, contained a bug
at some point that might cause this problem.

- Frank